Results 1 to 2 of 2

Thread: Info for those running an Elite-3x FF

  1. #1
    Join Date
    Feb 2016
    Location
    Hampstead, MD
    Posts
    445

    Default Info for those running an Elite-3x FF

    So since my transducer seems to work intermittently, some days it reads temp only, some days it reads temp, depth, but just displays scattered lines across the water column, and some days it works perfectly...I did some digging on the internet and found more than 1 source who had spoken to Lowrance and they admitted that the transducer for this particular model (elite 3x) is not powerful enough for a thru-hull mount on a kayak. I'm sure it depends on hull thickness, hence why when I mounted it somewhere else it seemed to work, but my current location is hit or miss. I bought the scotty transducer mount, so I will post back with my findings, I hope it alleviates the situation, since it'll allow me to run my transducer in the water. Also, the scotty mount is available for less than $20 for most places, and includes slip discs, the 241 locking deck mount, and some other pieces that are expensive individually (the rodholder kits themselves are usually over 25), so it's a great deal regardless.

  2. #2
    Join Date
    Feb 2016
    Location
    Hampstead, MD
    Posts
    445

    Default

    In case anyone was wondering, my new FF transducer setup now works perfectly. I haven't had an issue since I mounted the transducer on a scotty arm at the front of my kayak. I also returned the FF to factory default settings, so one of those 2 new approaches have made it work flawlessly since then (I'm obviously hoping a simply factory default reset wasn't the only thing giving me trouble)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •